• 0
Melde dich an, um diesem Inhalt zu folgen  
Folgen diesem Inhalt 0

Custom-ROMs - Warum nicht auch für das Wave 3?

Frage

Geschrieben

Ich weiß nicht, ob das Thema hier schon mal aufkam...

Nur ist derzeit zu beobachten, dass für das Wave I + II immer mehr Custom-Firmwares raus kommen.

Nun stellt sich mir die Frage, warum sich für das Wave 3 nix tut.

Ich denke, in diesem Bereich wäre auch einiges machbar.

Momentan habe ich schon eine Custom für die alten Waves erstellt.

Grundsätzlich hätte ich kein Problem, auch eine Version für das Wave 3 zu stellen.

nur stellt sich mir die Frage, ob nicht eventuell technische Hürden eine Rolle spielen.

Sollte also bedarf an einer Custom für das Wave 3 bestehen, einfach melden. ;)

Natürlich wäre ich hier auf die Rückmeldung von Wave 3-Besitzern angewiesen, da ich die Firmware dann nicht testen kann.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

281 Antworten auf diese Frage

  • 0

Geschrieben

seit mir nicht Böse,

aber,

eigentlich macht es doch keinen Sinn,

das wir versuchen, die apps_compressed.bin der M410K versuchen zu flashen...

weil,

(wir auch keine passende FactoryFs haben)

diese mit der DBT mit Sicherheit nicht will...

denn der Rest, würde nicht dazu passen (oder umgedreht)...

dieses Problem hatte ich auch schon, bei der 1.2er-Firmware,

mit der offiziellen, wenn ich es mit einigen Branding-Firmwares versucht habe...

(vergleicht mal die decrypt oder decompress, apps_..., miteinander, sind wirklich total verschieden)

und nun nochmal zur end.bin (also zu den letzten 1024 Bytes)

hier wird wirklich Bezug, auf irgendwas in der Datei genommen,

wenn man Glück hat, nur auf die Datei...

aber,

was die apps_compressed.bin oder die amss.bin angeht,

prüft der MultiLoader auch, das die BOOTFILES passen...

(das war auch schon, bei der 1.2er so)

mit meiner modifizierten Rsrc2, fürs Dreier, hatte ich nur Glück,

weil hier nur, das nicht-komprimierte-Zeug geprüft wurde,

aber nichts mit den BOOTFILES geprüft wurde...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

aber,

eigentlich macht es doch keinen Sinn,

das wir versuchen, die apps_compressed.bin der M410K versuchen zu flashen...

1.

Na der User mit dem M410K hätte gerne seine M410K Firmware wieder drauf...

http://forum.xda-developers.com/showthread.php?t=2068006

Momentan hat er halt die XXJKC...

2.

Ich hätte gerne ne M410K oder M210S für Spielzwecke...

Gut, schön blöd das ausgerechnet mein S8530 nicht zum Rumpfuschen zur Verfügung steht... und das S8600 ist außer Haus...

3.

Das dämliche Kies zu verstehen, wäre auch nicht schlecht...

MfG

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

nun gut, nochmal ein Test,

mit der apps_Compressed aus der M410KKRLF2,

mit DisableBadaIntegrity...

aber, das funktioniert auch nicht.

Download Start Ch[0]

Apps 29622.3KB OK[45.5s]

ERR : NAK_BAD_SEC_CODE 0

Error : CMD_USB_LOCK fail

nach nochmaligen fota-flash Bootschleife...

hier dann nochmal die originalen 1024 Bytes dran gehangen,

aber alles beim alten.

Download Start Ch[0]

ERR : NAK_BAD_SEC_CODE 0

Error : Apps Write [0.3s]

1 Person gefällt das

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

Ich werd mich nochmal mit Kies auseinandersetzen...

Also wie schonmal erwähnt.

Für mein S8530 war ich in der Lage die Firmware zu ziehen über den Punkt:

Firmware-Aktualisierung und Initialisierung + Seriennumer S/N Eingabe...

Das Gerät darf nicht angeschlossen sein. Sonst gibts halt diese Meldung mit nicht unterstützt...

Werde versuchen ein paar neue Kies Versionen auf anderen PCs zu testen... und mir noch ne Handvoll SN suchen...

Sinn der Übung ist... zu ergründen ob eventuell aus Versehen der Zusatz "Initialisierung" ne Full Firmware lädt... mit Boot + all den Schnickschnack...

Beim S8530 ist ja alles da... deswegen kann ichs nicht ausschliessen...

Auf auf in den Krampf... Mensch versus Kies und koreanischer Meldung... :haha2:

MfG

P.S.:

Nebenbei grab ich mich durch den JTAG Dump vom S8600... der 4 GB groß ist...

Sieht aus als ob da drauf war/ist...

S8600+XX+KK3

S8600+XX+KK5

[B]S8600+XX+KK7[/B]

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

:icon_roll

Der Server scheint OFF für derart Spielereien...

Da das schonmal ging... Ist das ne Falschmeldung...

Ich könnte... :haha2: ... später nochmal probieren.

Bis dahn hab ich eventuell noch ein paar mehr Seriennummern...

MfG

post-111375-14356902386252_thumb.png

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

Oh man.

Das war wieder ein lustiger Spass. ehm Spaß...

Ich hab gestern mehrere Stunden gebraucht um ne Android Seriennummer zu finden...

Weil z.B. S8000 nicht unterstützt wird...

Da dachte ich schon. bada wäre auch Game over und die hätten die Server geräumt...

Jedenfalls hab ich zwar noch saublöd auf dem anderen PC angestellt, weil Win 7 und einfach irgendwie alle Bildchen wegfliegen...

Aber irgendwann war das Ding fertig...

Ergebnis ist...

Wenn Kies ne Firmware zur Seriennummer ausspuckt.

Lädt das Ding die Firmware als Zip... wo die enc3 drinnen sind...

Habe 2 verschiedene S8600 Firmware geladen...

0 Bootloader

0 Full

So wie gehabt, die Update Versionen...

Die Meldung von gestern war also doch Serverprobleme... :banging:

M410K krieg ich grad nicht... diesmal ne andere Meldung...

Naja, immerhin ein bissel schlauer...

Mit leider 0 Nutzen... :hiding:

MfG

2 Personen gefällt das

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

S8600XXKL1_S8600OXCKL3_TPH

S8600JVKK4_S8600XFVKK1_XFV

S8600DXLD1_S8600OLBKK6_XXV

S8600DXLD1_S8600OLBKK6_XME

S8600JVKK4_S8600OJVKK2_XFE

S8600DXKK6_S8600OLBKK6_XSP

S8600DXLD1_S8600OLBKK6_XEV

S8600DXLD1_S8600OLBKK6_XTC

S8600XXKK7_S8600OXEKL1_VHC

S8600XXLD1_S8600OXDLD2_XSK

S8600XXLD1_S8600OXDLD2_XEH

S8600XXLA1_S8600OXDLA1_VDC

S8600BOKK6_S8600TMZKK6_TMZ

S8600JPLB1_S8600OJPLB1_TMC

S8600DXLD1_S8600OLBKK6_THL

S8600XXLD1_S8600OXDLD2_XEZ

S8600JPKL1_S8600OJPKK3_AFG

S8600XXKK7_S8600OXFKL1_SEB

S8600XXLD1_S8600OXELD1_SKZ

S8600XXKK7_S8600OXEKK5_SEK

S8600XXKK7_S8600OXCKK1_PHE

S8600JPLD1_S8600OJPLB1_THR

S8600XXLD1_S8600OXELD1_MTS

S8600AELE1_S8600SFRLE1_SFR

S8600XXKK7_S8600OXFKK7_MTL

S8600JPKL1_S8600OJPKK3_PAK

S8600JPLD1_S8600OJPLB1_MWD

S8600XXLC3_S8600PRTLC4_PRT

S8600XXLA1_S8600OXBLA1_NEE

S8600JPLA1_S8600OJPKK3_MID

S8600JPKL1_S8600OJPKK3_JED

S8600JPKL1_S8600OJPKK3_KSA

S8600FRLE1_S8600LPMLE1_LPM

S8600XXLD1_S8600OXELD1_KCL

S8600XXLD1_S8600ITVLD2_ITV

S8600BVLD2_S8600FTMLD2_FTM

S8600JPKL1_S8600OJPKK3_BTC

S8600JPKL1_S8600OJPKK3_EGY

S8600JVKK4_S8600OJVKK2_AFR

S8600XWLD2_S8600OXGLD1_ATO

S8600JPKL1_S8600OJPKK3_ABS

S8600NAKL1_S8600EPLKL1_EPL

S8600XXLC3_S8600OXFLD1_COA

S8600XWLD2_S8600OXGLD1_BSE

Keine Ahnung was alt oder eventuell noch unbekannt ist...

Vielleicht haben wir Glück und ELF Dateien sind irgendwo mit drinnen.. oder was anderes verwertbares...

MfG

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

bastle zwar momentan nicht mit Bada herum,

aber, das ist für die Bastler von Custom-Roms...

das ist mir bei der S8600XXKI9 doch aufgefallen,

hier ist die ShpApp 155 MB (163.059.138 Bytes) groß,

also, hier kann man nochmal 10 MB mehr reinpacken, als bei den letzten...

Templates_S8600_ShpApp.zip

1 Person gefällt das

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

Ich hab aus Versehen einem User geholfen seinem S8600 erstmal den Rest zu geben...

Leider hatte Kies nix ausgespuckt bei der Seriennummer... somit hatte ich 0 Ideen welcher Provider dahinterstecken könnte...

Das S8600 verlangt jetzt nach Qualcomm Treibern...

[B]QHSUSB_DLOAD[/B]
Boot Binary Download Start Ch[0]

Appsboot 338.7KB OK[1.1s]

OemSbl 1757.7KB OK[1.8s]

ERR : NAK_FLASH_ERROR 0

[COLOR="Red"]Error : partition Write [0.2s][/COLOR]

ERR : NAK_FLASH_ERROR 0

Download Start Ch[0]

Amss 16654.3KB OK[15.6s]

Apps 29622.3KB OK[54.1s]

_Open_Europe_Common 40370.2KB OK[73.5s]

(Low) 2980.3KB OK[1.9s]

ERR : NAK_INVALID_CONTENT 0

ERR : _Open_Europe_Common Erase

Mal sehen ob das mit den QC Treibern trotzdem noch von Multiloader gehandelt wird...

S8600XXKI9

Aufpassen mit dieser Version... Die Bootfiles zeigen große Unterschiede zur XXKJC... somit zur XXLD1, XXLL3... also nix für DBT...

Ich selbst hatte mal unbeschadet diese probiert:

PlatformDownloader_S8600_KI5.exe

Das dürfte der XXKI9 nahe kommen...

Das S8600 hat diese ignorert, beim Flashen... war also nochmal gut gegangen.

Also ACHTUNG beim Rumspielen mit den Bootfiles/Bootloadern vom S8600... am besten eh Pfoten weg davon. Also nicht auswählen.

Es gibt wieder lustige Unterschiede... auch in der Partitions Tabelle...

MfG

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben (bearbeitet)

Kann wer mal bitte diese hier auf Lauffähigkeit gegenchecken?

Insbesondere auch wegen der Polaris-Sache...

Ist nix Fertiges, sondern nur zu reinen Testzwecken...

Danke schon mal im Voraus...

bearbeitet von Taxidriver05

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

@ Taxidriver05,

entschuldige meine Worte...,

aber als Custom-Bastler solltest Du,

eigentlich die einfachsten Sachen verstehen...

hier haut erst mal nichts hin...

kurz gesagt:

zu Deiner,

GT-S8600_XEF_S8600XXLL3_S8600OXAMA1_D-A-CH_test

solltest Du schreiben, das es ein Update ist!

aber von der Dateistruktur her ist es fast eine Full, eigentlich ein Update, aber?...

weil nur,

die ShpApp_HD_D-A-CH.app einhalten ist...

kurz gesagt so würde das hinhauen:

als erstes die Full der S8600XXKJC_OXA flashen,

dann die,

GT-S8600_XEF_S8600XXLL3_S8600OXAMA1_D-A-CH_test

als Update flashen...

aber da gehört eigentlich die,

dsp1.bin und die

FFS_S8600_Open_Europe_Common_XXLL3.ffs

nicht dazu...

und bei einer Full,

sollte wenigstens die komplette ShpApp.app drin sein,

statt der abgespeckten HD...

aber egal,

Polaris bekomme ich nicht zu gesiecht... (DBT)

hab Deine Dateien noch nicht zerlegt, um festzustellen, was nicht stimmt,

keine Zeit...

noch eine Frage,

was soll das aber mit Deiner ...test.7z ,

weil da die DBT doch schon enthalten ist?

1 Person gefällt das

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

Ging mir eigentlich generell drum, ne 3er-Ful zu basteln...

Da sollte ich dann aber wohl eher mal an deiner Beispiel-FW ansetzen... Oder?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

eigentlich, ist das, mit meiner Beispiel-FW egal,

weil doch alle 2.0er zu 99% gleich gestrickt sind...

(egal ob, Wave 1, 2 oder 3)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

Für die Handvoll User mit dem 3er ist es wahrscheinlich uninteressant sich mit der ll3 zu ärgern, welche auch keinen einzigen Vorteil außer dem jüngeren Datum zur ld1 hat. Übrigens ruft der Mix mit dem 5er Panel einen deutlich höheren Akkuverbrauch bei Wlan hervor, beobachtet mit Gunters ld1 und Heros 2.2 - bringt dann eher auch nicht viel. Zusammenfassend ist die la1 fürs 3er die am besten funktionierende FW.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

hallo ax999,

glaube, das mit dem 5er-Panel und höheren Akkuverbrauch,

hab ich schon irgendwo mal gelesen..

nutze meine Waves eigentlich nur zum Basteln,

darum kann ich das nicht vergleichen...

glaube aber, das es daran liegt,

das einige komprimierte Dateien, nun dekomprimiert auf dem Wave sind,

aber dann müsste das alle Custom-ROMs betreffen?

aber interessant wäre das schon,

wenn Du Lust zum Testen hast,

könnte ich das 5er-Panel mal in die LA1 schmeißen...

(das ist nur ein Aufwand von einigen Minuten, da dauert das hochladen länger)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

@Gunter Sorry, das ich mich erst jetzt melde, bin gerade im Winterurlaub:icon_bigg Wenn du noch Zeit und Laune hast teste ich da gern mit, da ja die LA1 mein persönlicher Favorit ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben (bearbeitet)

@ ax999,

momentan wenig Zeit, melde mich am Wochenende dazu...

@ adfree,

hau das mal hierein...

ich schaue momentan selten in Bada-Foren (keine Zeit),

aber, was die letzten 1024 Bytes (end.bin) angeht,

CDABCDAB 0x0 START Header 4 Byte

00000000 0x4 Adresse MLoader 4 Byte

00000000 0x8?? 4 Byte

"Modelname" 0xC 4example S8500 5 Byte

"Leer" 00 0x11?? 27 Byte

fileextension 0x2C 4example mbn / bin 4 Byte

0000000006000000 0x30 "Header"?? 8 Byte

...

aber wenn man verschiedene end.bin,

von unterschiedlichen Waves und Dateien vergleicht,

kommt man vielleicht schneller dahinter?...

in der ...rc2 vom S2730,

ab Offset 0x11 steht noch was von, NativeSo...

also S2730E_NativeSo,

kein Plan, ob das noch zum Namen gehört...

edit:

in dem Fall, würde das E noch zum Namen gehören...

"Modelname" 0xC 4example S8500 5 Byte

also schon 6 Bytes,

weil das Ding, sich wirklich S2730E nennt?

post-719448-14356907155884_thumb.jpg

bearbeitet von Gunter33
1 Person gefällt das

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

Value		Address	at:	Description		size

CDABCDAB	 0x0		Header 			4   Byte

00000000	 0x4		Address MLoader		4   Byte

00000000	 0x8		???			4   Byte

"modelname"	 0xC		4example S8500		5   Byte

"empty" 00	 0x11		???			27  Byte

fileextension	 0x2C		4example mbn/bin	4   Byte

0000000006000000 0x30		"Header" ???		8   Byte

0200000002000000 0x38		MD5 Check ML ON/OFF	8   Byte

0008000000000200 0x40		???			8   Byte

79134679	 0x48		"Header" Signature 1+2	4   Byte

"RSA 512 Sig"1	 0x4C		4example enc modelname	64  Byte

"RSA 512 Sig"2	 0x8C		Looks like enc SHA1	64  Byte

00000000	 0xCC		???			4   Byte

"encrypted SEED" 0xD0		Info SEEDencrypted	64  Byte

		 0x110		SEED KeyS for Crypto	128 Byte

79134679	 0x190		"Header"		4   Byte

00001A00	 0x194		Address CDABCDAB/size	4   Byte

		 0x198		COPY of last 16 Byte	16  Byte

"RSA 512 Sig"3	 0x1A8		Looks like enc SHA1	64  Byte

"model"		 0x1E8		Device + Version String 12  Byte

"empty" 00	 0x1F4		???			52  Byte

"TkToolVer"	 0x228		Version of DecryptAlgo	15  Byte

"empty" 00	 0x237		???			17  Byte

		 0x248		MD5 Hash of file	16  Byte

"empty" 00	 0x258		???	- end		424 Byte
Das gilt erstmal nur für S8500 und S8530... boot + apps_compressed.bin. müßte aber auch für S8600 etc, gelten. Da Multiloader Standard... Das war ein bissel anstrengend... Enthalten sind 4 x 64 Byte Blöcke... 3 davon sind RSA 512 Signaturen, welche sich mit public key entschlüsseln lassen... Vor den 128 Byte SEED Schlüsseln, das sind mehrere... sind 64 Byte welche sich damit entschlüsseln lassen... Diese 64 Byte lassen sich einfach mit Wave_Remaker entpacken... Man nehme die end.bin der entsprechenden Datei... und packe die 64 Byte davor... click, click... Dann glotzt Dich bei XXLA1 S8500 sowas an:
S1-AGENT08

Korea

TkToolVer:1.8.0

MfG

1 Person gefällt das

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
  • 0

Geschrieben

@ adfree,

würde sagen, das die end.bin's eigentlich immer gleich gestrickt sind,

weil,

die Adressen scheinen zu stimmen...

hatte vor kurzem damit auch herumgespielt,

(glaube das war bei der Rsrc2 vom Dreier)

aber bin Beruflich momentan so eingespannt,

das ich eigentlich, zur Zeit, mit nichts spielen kann...

also, finde es Super, das Du damit noch tüftelst...

hab Dein Vorgehen, mal schnell mit der apps_compressed.bin

aus der S723EBOLH2/S723EDTMLH2 nachvollzogen,

das haut hin...

da kommt dann so etwas heraus:

(siehe Anhang)

post-719448-14356907198987_thumb.gif

1 Person gefällt das

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Geht einfach!


Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.


Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen  
Folgen diesem Inhalt 0