Melde dich an, um diesem Inhalt zu folgen  
Folgen diesem Inhalt 0

Nexus One - Rooten / Hacken

71 Beiträge in diesem Thema

Geschrieben

Für ADB muss USB Debugging eingeschaltet sein.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Alles nach der Anleitung gemacht und habe es auch nochmal hiermit versucht:

http://android.modaco.com/content/google-nexus-one-nexusone-modaco-com/298782/22-mar-erd79-epe76-superboot-rooting-the-nexus-one/ (ich habe ERE36B)

und es scheint auch zu funktionieren... Keine Fehlermeldung, nichts.. aber wenn ich das Telefon dann reboote startet Android (Modaco 2.1) und es kommen nur Fehlermeldungen "Touch Input musste beendet werden" "Telefon musste beendet werden" etc.

Telefon ist unbenutzbar...

Jemand eine Idee? Wenn ich dann Modaco 2.1 neu aufspiele (ohne Wipe) geht alles wieder... aber Root hab ich dann nicht

[Edit]

Unter der Build nummer steht:

"ERE36B with MCR 2.1, REBOOT REQUIRED"

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Es liegt wohl an der Recovery. Diese installiert das SU nicht richtig, daher verlierst du root.

Welche recovery hast du?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Habe das hier:

recovery-RA-nexus-v1.7.0-cyan.img

Eigentlich müsste ich doch durch das Modaco Rom schon Root haben?

"Features...

Superuser APK and su binary"

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Da hast du recht. Müsstest du. cyanogen hatte mit seinen ROMs das Problem auch schon, daraufhin hat AMON RA das recovery verändert.

Jetzt hat Modaco das Problem.

Lösung gibt es bisher keine vernünftige. Es sei denn, du findest noch eine Modaco ROM bis Version 1.8 oder versuchst es mit einer älteren Amon RA Recovery.

Ich weiß leider auch nicht mehr.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Hmm... schon merkwürdig ;)

Habe auch mal im Modaco Forum gefragt... Ansonsten werde ich es übers Wochenende wohl nochmal neu versuchen.

Also Recovery neu, wipen, neu flashen... Ggf auch Cyanogen... Eigentlich würde ich nur gerne EINMAL das Titanium Backup nutzen damit ich das nicht immer alles von Hand machen muss -_-

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Mal ein Update:

Das Rom wurde anscheinend gefixt und jetzt geht alles mit der neuesten Modaco Version :) Danke!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Hallo,

sobald ich die Eingabeaufforderung cmd und dann denn fastboot Pfad mit allem was dazu gehört eingebe,bekomme ich immer wieder die Meldung Pfad konnte nicht gefunden werden!!Könnt ihr mir evtl. nen Tip geben woran das Liegt :frown:

Mfg

Biggi760

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Ich versteh dich jetzt nicht genau. Bei welchem schritt bist du angekommen?

In der Regel kommt so ein fehler nur vor, wenn man im falschen Ordner ist oder den Pfad falsch eingegeben hat.

Bist du dir 100% sicher, dass du alles richtig geschrieben hast?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Wie muß ich eigentlich mit dem AndroidSDK umgehen?Runter geladen habe ich es und wie geht es nun weiter....?

Mfg

Biggi760

P.S. Können es auch sehr gerne über PN regeln!!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Neenee, dafür ist das Forum gedacht. So können wir unsere Erfahrungen doch lieber teilen.

Also, das AndroidSDK hast du entpackt, ja?

Fastboot.zip hast du auch entpackt?

- Nexus One anstöpseln

- Nexus One ausschalten

- Trackball gedrückt halten und bei gedrücktem Trackball das Nexus wieder einschalten

- unter Windows die Eingabeaufforderung starten

- in dieser Eingabeaufforderung in den "Fastboot" Ordner navigieren (in den Unterordner namens Fastboot in dem fastboot Ordner!! Beim entpacken des zips hat man nämlich in dem Ordner Namens fastboot einen Ordner der auch fastboot heisst. So, wie c:\downloads\fastboot\fastboot\

- Eingeben: fastboot-windows oem unlock

Damit hast du fastboot drauf.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Im Post #1 ist übrigens ein fastboot-windows.exe auf der Kommandozeile zuviel :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Danke für den Hinweis! Wird nachher behoben

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Besser spät als nie:

Ich glaube ich hab es jetzt richtig berichtigt :P

Falls jemand vorher Probleme mit der Anleitung hatte, bitte noch einmal probieren!

Danke nochmal

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Hallo!

Habe es heute erneut nach der Anleitung probiert und es kommt immer und immer wieder der gleiche Fehler bei der Instalation von Fastboot das der Pfad nicht gefunden wurde.Was muß bzw. brauche ich alles an Programme um es endlich mal zu Roote!?Habe bis lang nur Fastboot und Superboot runter geladen!!Wie schaut es mit dem SDK und dem USB Driver aus!?Vieleicht hat ja nochmal jemand eine Komplette Anleitung von Beginn an wie man vorgehen kann.....wie sieht es aus mit der Fehlermeldung ADPWIN dll. fehlt!!!Was soll bzw. muß ich machen!??

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Sobald ich WIN+R drücke und dann cmd eingebe öfnet sich ein Fenster wo drin steht C:\Users\Kay>

Was soll ich dort eingeben?Ich habe dahinter dann denn Pfad eingegeben wo ich denn fastboot Ordner habe!!!Bekomme dann immer wieder die Meldung das AdbWinApi.dll fehlt.....ich weiss langsam wirklich nicht mehr weiter!!!!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Sobald ich WIN+R drücke und dann cmd eingebe öfnet sich ein Fenster wo drin steht C:\Users\Kay>

Was soll ich dort eingeben?Ich habe dahinter dann denn Pfad eingegeben wo ich denn fastboot Ordner habe!!!Bekomme dann immer wieder die Meldung das AdbWinApi.dll fehlt.....ich weiss langsam wirklich nicht mehr weiter!!!!

Hi Biggi

Ich hatte damals auch so meine Probleme was gescheites hier zu finden.

Habe dann diese Anleitung gefunden und damit ging es ganz gut.

Kannst ja auch mal Probieren.

Unlock Nexus One.doc

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben

Hi,

dank Dir steve72,werde es nach der Anleitung mal probieren und falls es dann nicht klappen sollte,werde ich das Rooten sehr wahrscheinlich wohl sein lassen müssen!!!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben (bearbeitet)

Ich habe hier ein paar Dateien zusammen gestellt für Leute die gerne die FRG33 in original ROM benutzen wollen aber superuser rechte im Image haben wollen + Fingerprint FRF91 für vollen Market zugriff.

Leider gibt es auf Modaco noch kein superroot für das FRG33.

Die älteren funktionieren nicht mit dem NexusOne LCD > kein Bild.

Voraussetzung:

Nexus One unlocked mit Original FRG33

android-sdk-windows

android-sdk USB-Treiber

N1_boot_FRG33_rooted.rar

superuser-FRG33.rar

Die rar Dateien entpacken und Inhalt nach \android-sdk-windows\tools

Kleine Anleitung:

1. (root.img flashen)

-Nexus one in fastboot modus starten: Am windows Rechner cmd.exe(command line) mit Administrator Rechte starten und in \android-sdk-windows\tools rein.

- boot.img flashen in der command-line mit

fastboot flash boot boot.img

2. NexusOne neu starten und hochfahren lassen, im Gerät unter Einstellungen > Anwendungen > Entwicklung > USB-Debugging aktivieren.

3. Am PC mit dem normalen Windows Explorer in \android-sdk-windows\tools rein und die superuser.bat ausführen.

4. NexusOne neu starten . Wenn alles geklappt hatte sollte jetzt der Befehl su , superuser Genehmigung und Fingerprint FRG91 im Original FRG33 ROM drinnen sein.

MFG

bearbeitet von Omnia-bald

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Geschrieben (bearbeitet)

Moin zusammen,

wenn ich bei diesem Schritt bin:

In Windows: öffnet die Eingabeaufforderung ([WIN]+[R], dann cmd eingeben) und gebt dann den Pfad der fastboot-windows.exe ein, dann oem unlock

Die Eingabe sieht dann ungefähr so aus, kommt drauf an wo ihr es gespeichert habt:

C:\Users\Patrick\fastboot\fastboot-windows.exe oem unlock

Wichtig ist, dass ihr das ganze OHNE Anführungsstriche eingebt oder einfügt.

Jetzt drückt ihr [ENTER].

Kommt in der Eingabeaufforderung: Waiting for Device

Und nu?

Edit: Hab es geschafft. Im Modaco Forum gab es den Tip man sollte lieber den Ordern Superboot nehmen.

sprich:

Bspw wie bei mir: c:\sdk\superboot\fastboot-windows.exe oem unlock.

Dann kommt kein Waiting for device mehr, sondern es kommt im Phone gleich der Hinweis für Unlock Bootloader...

bearbeitet von FS61

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Geht einfach!


Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.


Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen  
Folgen diesem Inhalt 0