Jump to content
  • 0
Melde dich an, um diesem Inhalt zu folgen  
Taxidriver05

Deutscher badaDROID-Support-Thread

Frage

Taxidriver05

Da die Verbreitung diverser badaDROID-Versionen immer mehr unter den Wave I & II-Nutzern Einzug hält und immer wieder Fragen zur Installation und Verwendung aufkommen, soll dieser Thread den deutschsprachigen Nutzern eine Plattform bieten, Fragen zu besprechen.

Daher ist dieser Thread nicht nur an Nutzer der ROMs gerichtet, sondern ebenso an Entwickler, welche sich auch unter xda-developers.com einbringen.

Um wiederkehrende Fragen im Vorfeld zu vermeiden, möchten wir einige Grundlegende Fragen gleich klären.

Kann ich badaDROID auch mit bada 1.x nutzen?

Nein! Um überhaupt eine badaDROID-Version nutzen zu können, ist bada 2.0 zwingend erforderlich!

Warum gibt es keine badaDROID-Version für das Wave 3?

Dass es für das GT-S8600 und andere Geräte keine badaDROID-Versionen gibt, liegt daran, dass das Wave 3 einen anderen Sicherheitsmechanismus für die Verschlüsselung der relevanten Dateien nutzt.

Ob und wann es eine Version für das GT-S8600 geben wird, ist derzeit noch nicht abschätzbar. Ebenso müssten Treiber für das Gerät neu portiert werden.

Woher bekomme ich die ROMs überhaupt?

Da die Vielfalt an badaDROID-Versionen stetig zunimmt, haben wir euch hier denn Download der notwendigen bada-Dateien und eine Übersicht der aktuell verfügbaren badaDROID-ROMs zusammen gestellt.

Wie installiere ich badaDROID überhaupt?

Wie ihr badaDROID auf euer Wave bekommt, haben wir euch ebenfalls hier erklärt.

Welche Arten von badaDROID-Versionen gibt es?

Im Grunde gibt es drei Typen von badaDROID-Versionen.

Zum Einen gibt es eine Standard-Version (z.B. CM 10.1), die sich über eine entsprechende Tastenkombination starten lässt.

Bei der SD-Version wird badaDROID von einer externen SD-Karte installiert und betrieben.

Die NAND-Version ist wohl die komplexeste Variante. Hierbei sind die Daten so verändert, dass mit dieser Version bada praktisch deaktiviert wird und sich Android normal über den Power-Knopf starten lässt.

Kann ich badaDROID im täglichen Gebrauch nutzen?

Grundsätzlich ja. Dennoch erfolgt der produktive Einsatz auf eigenes Risiko.

Denn die derzeit verfügbaren Versionen weisen noch immer Fehler auf, die nicht unerheblich sind.

Wo kann ich Bugs melden?

Grundsätzlich können Bugs gern hier gemeldet werden. Dies sollte dann mit entsprechenden Logfiles erfolgen.

Bevorzugterweise sollte man sich jedoch an den Anbieter der jeweiligen ROM im xda-Forum wenden.

Noch Fragen?

Ihr seid der Meinung, dass wir eine wichtige Frage noch nicht beantwortet haben?

Dann stellt eure Frage einfach hier im Thread!

Euer badaNIA-Team!

Diesen Beitrag teilen


Link zum Beitrag

Recommended Posts

  • 0
Gunter33

nun gut, dann hau ich das auch noch, hierein...

da mit der cm-10.1-wave-v2.1 Bluetooth

auf dem Wave2 nicht funktioniert,

(hier hilft es auch nicht den BT_Fix_Wave2 zu installieren)

könnt ihr einfach Abhilfe schaffen:

einfach unter:

Dateimanager -> system -> vendor -> firmware,

die bcm4329_s8500.hcd löschen

und

die bcm4329_s8530.hcd in bcm4329_s8500.hcd umbenennen…

nach dieser Änderung, das Wave2 neu starten…

dann haut Bluetooth auf dem Wave2 wieder hin…

damit das funktioniert,

vorher noch den Zugriffsmodus auf Root-Zugriffsmodus umstellen…

vielleicht kann das einer auf XDA schreiben, keine Zeit…

Diesen Beitrag teilen


Link zum Beitrag
  • 0
triangolum

Danke für diese Zusammenfassung.

Könnt Ihr bitte noch die Vor und Nachteile der drei Versionen aufzeigen?

Eventuell auch den Funktionsumfang?

Ist zudem auch schon etwas bekannt ob es Modder geben wird die Tizen auf das Wave I und II bringen könnten?

Das sollte doch eigentlich leichter gehen oder?

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Gunter33

was die Vor und Nachteile der Versionen sind, kein Plan...

den meisten Support bekommst halt für die cm-10.1-wave-v...

(momentan v2.1)

was Tizen auf das Wave I und II angeht:

erst mal abwarten bis Tizen überhaupt den Weg auf Smartphones findet...

aber leichter gehen wird das mit Sicherheit nicht...

aber kein Plan,

ob das noch Sinn macht,

denn die Waves sterben doch langsam aus...

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Gunter33

bin zu faul das auf XDA zu schreiben,

denn da müsste ich das übersetzen (also etwas nachdenken, da bin ich gerade, zu faul...)

aber hab gerade nochmal, 10 minuten, mit der cm-10.1-wave-v2.1 gespielt...

es ist interessant, wie sich bugs durch die sources ziehen...

denn was bluetooth auf dem wave2 angeht,

hier wird immer die "bcm4329_s8500.hcd" geladen,

(die kommt alphabetisch vor 8530)

also diese (echte Datei) hat priorität, vor dem symbolischen link (bcm4329.hcd)

der eigentlich auf die entsprechende datei verweist...

irgendwo im system, ist das so definiert,

das immer alphabetisch die erste datei geladen wird,

die mit bcm4329_... beginnt...

kann sein, das dies schon irgendwo im kernel so definiert ist...

hab es gerade nochmal versucht,

hab die "bcm4329_s8500.hcd" in "bcm4329_s8540.hcd" umbenannt,

schon haut das wieder hin...

also wird, hier die dann die "bcm4329_s8530.hcd" geladen...

(bild4 im anhang)

man kann auch die "bcm4329_s8500.hcd" löschen

und die "bcm4329_s8530" in "bcm4329_1234.hcd" umbenennen,

dann haut das auf dem wave2 auch wieder hin...

also wird, hier die dann die "bcm4329_1234.hcd" geladen...

(bild3 im anhang)

und wenn ich die "bcm4329_s8500.hcd" lösche

und in "bcm4329_s8530.hcd" in "bcm4329_s8500.hcd" umbenenne,

haut das auch wieder hin...

(hier wird nicht mal der symbolische link erstellt...)

(bild5 im anhang)

also die setmodel.sh nicht verändert...

aber ich wäre auch zu faul, nach dem bug zu suchen,

würde einfach die 4 dateien, in einen neuen Ordner auslagern

und die setmodel.sh anpassen...

villeicht hat das volk204, inzwischen selber herausgefunden?...

wie gesagt, das ist mir nach ein paar minuten spielen aufgefallen...

will mich momentan, aus zeitlichen gründen, nicht mit badadroid befassen...

(aber mal ehrlich, so interessant finde ich das nicht...)

glaube, diesen text zu schreiben, hat länger gedauert als mit der firmware zu spielen...

post-719448-14356925162173_thumb.png

post-719448-14356925162621_thumb.png

post-719448-14356925162916_thumb.png

post-719448-14356925163234_thumb.png

post-719448-1435692516355_thumb.png

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Taxidriver05

Hab's mal für Dich bei xda rein geballert...

Vielleicht hat's da ja wirklich noch keiner gemerkt... :haha2:

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Gunter33

war gestern, wahrscheinlich, schon etwas Spät...

(Kommentar auf

https://www.badania.de/2013/11/baddroid-android-4-4-kitkat-auf-dem-wave-gt-s8500-gesichtet/comment-page-1/#comment-9034

)

eigentlich ist die MD5-Datei schnell erstellt...

(nandroid.md5)

wollte eigentlich was dazu schreiben,

aber nun ist eine neue Version raus...

hab diese auf dem Zweier getestet, da funktioniert erstmals nichts...

(Bild 1 im Anhang)

dann hab ich unter Linux einige Dateien ersetzt.

neues tar.gz-Archiv erstellt,

die MD5-Datei neu erstellt

und wieder aufs Zweier geschmissen...

(((will meine Bastelei nicht öffentlich machen, wegen den sources,

die hab ich zwar lokal, aber wenig Zeit...)))

nun funktioniert Anrufen, Bluetooth

und WLAN fast (glaube hier muss man noch was umstellen)

mit dem Display-Treiber fürs Zweier ist auch noch was Faul...

(letztes Bild, im Anhang)

noch was,

mit der Beschreibung von hero355 komme ich nicht Klar,

mache es immer noch nach dieser, Stichpunktartigen, Beschreibung:

https://forum.xda-developers.com/showthread.php?t=2482214

das haut hin...

edit:

fast vergessen, es geht nun um die:

AOSP 4.4 (KitKat) Stable Full S8500 & S8530

aber finde, volk204 macht das besser,

Er geht da auch besinnlicher ran...

post-719448-14356925343072_thumb.png

post-719448-14356925343358_thumb.png

post-719448-14356925343649_thumb.png

post-719448-14356925343944_thumb.png

post-719448-14356925344455_thumb.png

post-719448-14356925344881_thumb.png

post-719448-14356925345175_thumb.png

bearbeitet von Gunter33

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Gunter33

noch was,

(kein Plan, ob sich dafür überhaupt einer interessiert...)

falls jemand die AOSP 4.4 (KitKat)... auf dem Wave2 hat

und spielen möchte...

hab ich im Anhang, ein Patch gebastelt (ist nur fürs Wave2 !!!)

dann funktioniert wenigstens Anrufen und Bluetooth...

WLAN und mobiles Internet, wahrscheinlich, nicht...

(zu wenig Zeit...)

den Patch einfach auf die Speicherkarte kopieren,

und dann im "Recovery - Modus" starten,

nun auf "Install Zip"

dann auf "Choose zip from /storage/sdcard0"

nun auf "w2_patch.zip" und dann auf "Yes - Install w2_patch.zip"

wenn das durch ist...

nun einfach die rechte untere taste gedrückt halten bis das wave2 neu startet...

edit:

wegen busdriver+, auf XDA

versuch mal den w1_patch.zip... (ist fürs Wave1 )

bearbeitet von Gunter33

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Gunter33

dann wird es auf dem Einser vielleicht hinhauen...

(noch nicht getestet, zu wenig Zeit...)

"w1_patch.zip" ist das RIL-Update,

hab nur den Update-Link für die AOSP 4.4 (KitKat)... angepasst...

run_program("/sbin/busybox", "mount", "-t", "ext4", "/dev/block/mmcblk0p2", "/system");

edit:

hab die Anhänge oben gelöscht...

so haut es hin...

ist bestimmt auch das originale update,

hab es trotzdem mal selber gebastelt...

nun haut's hin...

mount("ext4", "EMMC", "/dev/block/mmcblk0p2", "/system");

package_extract_file("system/bin/ipc-modemctrl", "/system/bin/ipc-modemctrl");

set_perm(0, 0, 0644, "/system/bin/ipc-modemctrl");

package_extract_file("system/lib/libmocha-ril.so", "/system/lib/libmocha-ril.so");

set_perm(0, 0, 0644, "/system/lib/libmocha-ril.so");

run_program("/sbin/umount", "/system");

patch.zip

bearbeitet von Gunter33

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Taxidriver05

Okay...

Hab mal in den Speicher geschaut...

Mit der Android 4.4er haben wir gut 1 GB auf dem internen Speicher... :haha2:

Das ist mal ne ganz andere Hausnummer, als mit bada...

Mal dumm gefragt...

Wie bekommt man mit dem Wave (I/II) nen Screenshot unter Android hin?

Diesen Beitrag teilen


Link zum Beitrag
  • 0
busdriver+

@Gunter33,

erstmal danke für den Patch. Bei mir funktioniert Bluetooth aber immer noch nicht. Die zip lässt sich zwar installieren aber es ändert sich nix.WLAN funtioniert schon seit anfang an.

@Taxidriver05:

Geh mit der Sperrrentaste ins Menü zum herunterfahren. Das steht Screenshot...

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Gunter33

hab es auch gerade mitbekommen,

mit den Patch's haut das bei mir auch nur bedingt hin,

manchmal klappt das, nach einem Neustart nicht mehr...

wenn ich alles unter Linux zusammenbastle, haut alles hin...

bin vielleicht zu hektisch, mal schauen...

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Taxidriver05

Okay...

Nachdem ich jetzt den Patch eingebaut habe, ist jetzt mein Mobilfunknetz wieder weg... :(

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Gunter33

hätte vielleicht noch Test schieben sollen...

wie gesagt, ich spiele auf dem Wave2...

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Taxidriver05

So... Nach diverser Fummelei läuft das jetzt.

Review folgt...

Geschrieben mit meinem Samsung GT-S8530 mit Android 4.4

Diesen Beitrag teilen


Link zum Beitrag
  • 0
busdriver+

Okay...

Hab es jetzt auch hinbekommen , das das Handy das Netzwerk findet. Irgendwie muss Daten Roaming bei mir aktiviert werden. Nach dem reboot findet er das Netz dann auch ohne Probleme wieder ;)

Gesendet vom Wave I via KitKat 4.4

Diesen Beitrag teilen


Link zum Beitrag
  • 0
777hejo

Hi zusammen,

weiss jemand, ob das Handy dann auch normal herunter fährt wenn man es ausschalten will? Bei allen anderen rom`s rebootet das handy ja wenn ich es ausschalten will (glaub mal bei allen, bin aber nicht 100 % sicher).

Und, wenn ich das richtig gelesen habe, ersetzt dass dann Bada? Ist das richtig?

Dies nur als Frage; ich brauche das Bada nicht mehr, wenn dieses hier vernünftig läuft.

Gruß

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Taxidriver05

Das Ding versucht genauso nen Reboot...

Keine Ahnung, was da nicht passt...

Und ja, bada wird damit komplett gelöscht, also nicht nur deaktiviert. Denn, damit die ROM drauf passt, muss die bada-Partition formatiert werden.

Und genau, WEIL diese Version noch nicht 100%ig zuverlässig läuft, können wir derzeit noch keine Downloads anbieten...

Diesen Beitrag teilen


Link zum Beitrag
  • 0
777hejo

Vielen Dank für die schnelle und klare Aussage :thankyou:

Dann warte ich noch, bis es eventuell eine 100%ige, gut laufende Version gibt.

Ich habe aktuell die 4.3.1 B.U.X auf dem Wave (hoffe das darf ich hier schreiben), und die läuft ja auch schon bestens. Nur nervt mich das mit dem reboot anstatt dem ausschalten und ich will nicht jedes mal den Akku raus holen wenn ich das Ding komplett abschalten will.

Ich bin kein Experte, aber eventuell könnte das ja an den Fota bzw Boot-Files liegen? Nur so eine Idee.

Weiterhin viel Erfolg an alle Beteiligten,

Gruß

Diesen Beitrag teilen


Link zum Beitrag
  • 0
Taxidriver05

Viel gravierender finde ich im Moment, dass sich mein Wave kurz nach dem Booten immer automatisch in den Flugmodus schaltet...

Ich bekomm da auch ums Verrecken kein Netz mehr rein.

Hab schon diverse Patches Probiert...

Doch kurz nachdem die SIM entsperrt wurde, kommt der Flugmodus...

Anbieter ist o2...

Diesen Beitrag teilen


Link zum Beitrag

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gast
Diese Frage beantworten...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Melde dich an, um diesem Inhalt zu folgen  

×
×
  • Neu erstellen...

Wichtige Information

Bitte beachten Sie folgende Informationen: Nutzungsbedingungen und Impressum & Datenschutzerklärung. Wir haben Cookies auf deinem Gerät platziert, um die Bedienung dieser Website zu verbessern. Du kannst deine Cookie-Einstellungen anpassen, andernfalls gehen wir davon aus, dass Du damit einverstanden bist.