Jump to content
Melde dich an, um diesem Inhalt zu folgen  
krteddy

LG P970 Optimus Black - Root Methoden

Recommended Posts

chimalia

Ok, probier mal folgendes:

Du musst mit der Konsole in den Superone-Click Ordner und dort in den Unterordner ADB, bei mir sieht das Kommando dorthin wie folgt aus:

cd C:\Dokumente und Einstellungen\XXX\Eigene Dateien\Downloads\SuperOneClickv2.1.1-ShortFuse\ADB

jetzt den Befehl "adb shell" eingeben.

Und jetzt kannst Du wie in der Anleitung beschrieben fortfahren.

Sorry, das hätte ich noch erwähnen sollen, ich werde die Anleitung entsprechend anpassen.

Diesen Beitrag teilen


Link zum Beitrag
NitschoO

Okay werd es später nochmal versuchen, mir gerad die lust vergangen ^^ liegt es vllt auch daran das ich vom superclick die 1.9.5 verwende?

Diesen Beitrag teilen


Link zum Beitrag
chimalia

So, die Anleitung habe ich angepasst.

Ist eigentlich egal welche Version...

Ich verwende die SuperOne-Click 2.1.1.

Diesen Beitrag teilen


Link zum Beitrag
NitschoO

ick werd irre ^^

wo soll ich adb shell eingeben ?`in der eingabeaufforderung? wenn ich im unterordner ADB bin???

so ?

sobiywxx.png

und dahinter gleich shell adb ?

EDIT: Bilder dürfen selbstverständlich verwendet werden um die Anleitung vllt bissel anschaulicher zumachen :)

bearbeitet von krteddy
Zusammen geführt um die Übersichtlichkeit sicher zu stellen!

Diesen Beitrag teilen


Link zum Beitrag
chimalia

Genau, in den Ordner ADB navigieren und dann "adb shell" eingeben.

Dafür muss man natürlich im Ordner drin sein :-)

Diesen Beitrag teilen


Link zum Beitrag
NitschoO

Sorry aber ich verstehs glaub ich nicht Oo

kannst du evtl mal nen bild davon hochladen?

von eingabeaufforderung und wie man was eingeben muss Oo

wäre nett :)

Diesen Beitrag teilen


Link zum Beitrag
NitschoO

so danke, das hat mir schonmal weiter geholfen.

ist das normal das da steht ,,No such file or directory'' ??

bxfbevjh.png

Diesen Beitrag teilen


Link zum Beitrag
chimalia

Siehst du die stelle an dem du ein "cat /tmp/su" machst?

Das kann nicht funktionieren :-) er weiß ja gar nicht das der tmp Ordner auf der SD-Karte liegt.

Das musst du noch vor dem /tmp/su angeben und vor den anderen Dateien auch die er sich von der Karte holt.

Also dann in etwa so:

cat SDcard/tmp/su > /system/bin/su

usw. :-)

Diesen Beitrag teilen


Link zum Beitrag
NitschoO

also anstatt SDcard halt den Laufwerksbuchstaben?

Davor das cat auch ja?^^

Diesen Beitrag teilen


Link zum Beitrag
chimalia

Genau, also dann in etwa so:

Laufwerksbuchstabe der SDKarte/tmp/su > /system/bin/su

Du musst halt mal gucken wie er die SD-Karte mounten tut.

Aufjedenfall musst du halt den kompletten Pfad angeben zur su-Datei.

Diesen Beitrag teilen


Link zum Beitrag
NitschoO

also ich hab jetz es jetz

so eingegeben:

cat H:/tmp/su > /system/bin/su....

und wieder findet er den file nit ...

hmm komisch

Diesen Beitrag teilen


Link zum Beitrag
stp402

Hallo,

ich denke du, daß du den internen Pfad zur SD-Card angenem mußt.

cat /mnt/sdcard/tmp/su > /system/bin/su....

Gruß stp402

Diesen Beitrag teilen


Link zum Beitrag
chimalia

Also, das ganze scheint so zu funktionieren:

sdcard/tmp/su > /system/bin/su

Bei NitschoO hat es aufjedenfall funktioniert :-)

(Hab das mit ihm per PN geklärt um hier nicht alles voll zu Spamen :-) )

bearbeitet von chimalia

Diesen Beitrag teilen


Link zum Beitrag
NitschoO

Ganz fettes DANKE für eure Hilfe Jungs!!!

nach langem in und her gehts jetz endlich.. ich hoffe ich konnte hier mit den paar bildern weiter helfen...

ich musste nicht den Laufwerksbuchstaben einsetzen sondern sdcard, quasi so

cat sdcard/tmp/su > /system/bin/su

das wars, den rest schön nach anleitung... DANKE!

Diesen Beitrag teilen


Link zum Beitrag
hinzi

Da es zur Zeit noch nichts für das Gerät gibt wird Ihm nur das überbleiben. Oder er legt es zur Seite bis was kommt das geht.

Gruß TEDDY

Hallo. Mir ist das selbe passiert. Habe es ein geschickt und nun muss ich abwarten.

Diesen Beitrag teilen


Link zum Beitrag
Krieg

Methode 2 Funktioniert ja mal gar nicht immer wieder Hängt sich das Programm

auf -.-

Und bei Methode 1

solltet ihr auch mal hin schreiben wo man da GingerBreak zu finden hat:

unter Polar Office.

_ExternalSD

da findet man es dann auch ;D

Wen ich GingerBreak nun Starte steht da

-You have SD card insereted and mounted

-USB debugging is enabled?

Was soll das nun heißen?

bearbeitet von Krieg

Diesen Beitrag teilen


Link zum Beitrag
chimalia

@Krieg

Das das Programm sich aufhängt ist normal, steht auch in der Anleitung.

Wer lesen kann ist klar im Vorteil :-)

Diesen Beitrag teilen


Link zum Beitrag

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gast
Auf dieses Thema antworten...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Melde dich an, um diesem Inhalt zu folgen  

×
×
  • Neu erstellen...

Wichtige Information

Bitte beachten Sie folgende Informationen: Nutzungsbedingungen und Impressum & Datenschutzerklärung. Wir haben Cookies auf deinem Gerät platziert, um die Bedienung dieser Website zu verbessern. Du kannst deine Cookie-Einstellungen anpassen, andernfalls gehen wir davon aus, dass Du damit einverstanden bist.