Jump to content
mlerch

Huawei Mate S - Root / Rooten

Recommended Posts

TheFlown

So nun hab ich das Mate erfolgreich gerootet und nachdem ich die Sim Karte eingelegt habe wurde ein EMUI Update geladen...

Leider wird das aber nicht richtig installiert :huh:

Das Handy bootet in TWRP und versucht da die Update.zip zu flashen, bricht aber mit

 

"E:Error executing updater binary in Zip ´/external_sd/update.zip´

 

Der Fehler sagt ja nicht wirklich viel aus...

 

Hat jemand einen Tip woran das liegen könnte ?

 

Edit : das Problem scheint daher zu kommen weil meine System partition schreibgeschützt ist aber ich bekomme das einfach nicht geändert,  hat da jemand Erfahrungen ?

bearbeitet von TheFlown

Diesen Beitrag teilen


Link zum Beitrag
mlerch

Ein offizielles Update benötigt immer auch ein Stock Recovery!

Da Du aber TWRP (=Custom/alternatives Recovery) installiert hast, wird das Update entsprechend fehlschlagen.

 

Um dieses auszuführen musst Du wieder das original Recovery per fastboot flashen und dann das Update ausführen.

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

Hast du einen Tip von wo ich das original Recovery bekommen kann?

Danke im voraus

Gesendet von meinem HUAWEI CRR-L09 mit Tapatalk

Diesen Beitrag teilen


Link zum Beitrag
mlerch

Ja, einfach aus der Firmware B114 mit dem Huawei Update Extractor die Recovery.img extrahieren und via fastboot (fastboot flash recovery recovery.img) flashen.

 

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

Verdammte Kacke, das ging leider total in die Hose....

Habe mit adb das Stock recovery geflasht, ging auch ohne Fehlermeldung durch

Danach neu gestartet und nun in einer Bootloop... 

Das Vodafone Branding wird eine Weile angezeigt und dann startet das Handy neu.

Ich kam in das EMUI Menü und habe ein Factory Reset 

 

Jetz kommt immer ganz kurz ein Notfallmenü in dem ich aber nichts auswählen weil das Handy sofort neu startet....

 

Bin gerade zimlich ratlos, habe ich jetzt einen teueren Briefbeschwerer ???

 

Hiiiiiiilllfffffeeeeeeee

 

Edit1: Bin jetzt ins Erecovery gekommen, mit WLAN verbunden und auf "Download new Version and Recovery" gegangen, klappt nicht mit dem Fehler "Getting Package Info failed"

 

Edit 2:

Ich komme wenigstens noch in den FASTBOOT&RESCUE MODER also hoffentlich ist da noch was zu retten....

Was mache ich jetzt als nächstes?

bearbeitet von TheFlown

Diesen Beitrag teilen


Link zum Beitrag
mlerch

Hattest Du ein Branding auf dem Mate S?

Welche Firmware war bei Dir installiert bevor Du TWRP geflasht hast?!

Diesen Beitrag teilen


Link zum Beitrag
Pille_S5830

Nach der Anleitung mit der Webseite bin ich auch vorgegangen.

Funktioniert einwandfrei.

Gruß Pille

Gesendet von meinen Huawei Mate S mit Tapatalk

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

ich hatte mir zum Glück mal diese update.zip gesichert die das Handy runter geladen hatte und habe die jetzt auch mal extrahiert

aber mit der recovery.img habe ich das selbe Problem....

 

Würde es Sinn machen evtl. mal die boot.img nochmal zu flashen ?

 

Oder eine komplette Firmware Datei ???

 

Ich kann derzeit wieder ins TWRP und in den Fastbootmodus starten

Diesen Beitrag teilen


Link zum Beitrag
mlerch

Wenn Du ins TWRP starten kannst, dann wurde das Original Recovery nicht geflasht!!!

 

Flash mal Boot.img und danach Recovery.img und achte darauf, ob der Flashvorgang auch erfolgreich ist!

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

Ja ich habe zwischenzeitlich nochmal versucht mit TWRP ein Nandroid Backup ein zu spielen aber das ging auch nicht

weil wohl die systempartion schreibgeschützt ist.

 

Die Recovery lässt sich ohne weiteres Flashen, ergebniss OKAY

Die BOOT.img lässt sich nicht flashen, error: connot load `boot.img`

 

mein syntax beim flashen : fastboot flash boot BOOT.img

Diesen Beitrag teilen


Link zum Beitrag
mlerch

Ist unter Einstellungen -> Entwickleroptionen -> OEM Entsperrung aktiviert?

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

wenn ich das wüsste...

leider komme ich ja garnicht mehr ins system

 

gibt es keinen weg die Firmware komplett neu drüber zu bügeln?

 

In diesem Notfallmenü das immer ganz kurz zu sehen ist steht übrigens in der Überschrift dass

nicht auf die Benutzerdaten zugegriffen werden konnte

 

Ich hätte dann therotisch u.a. die wahl ein update runter zu laden und zu installieren aber bevor ich

das auswählen kann startet das Ding wieder neu.

 

So ein Mist, hätte ich am besten erst gar nicht versucht dieses dämliche Update zu installieren

bearbeitet von TheFlown

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

Also irgendwie habe ich wohl nun das OS komplett zerschreddert, TWRP hat mir mitgeteilt dass kein

OS installiert ist. Nun habe ich nochmal mit ADB die original Recovery und Boot.img geflasht was auch

funktioniert hat aber mich trotzdem nicht weiter bringt denn nun bleibt das Handy beim Huawei Logo hängen,

klar ist ja auch kein OS drauf...

 

.... kann man irgendwie die komplette Firmware aus dem anderen Beitrag (die ohne Branding) mit fastboot flashen oder

geht das nur wie dort beschrieben aus dem System heraus?

 

Meine einzige Hoffnung ist mit ADB eine vollständige Firmware zu flashen, das muss doch irgendwie gehen oder?

 

 

bearbeitet von TheFlown

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

Juchuuuuuu es läuft wieder :rolleyes:

 

Ich weiß nicht was ich alles versucht habe aber irgendwann hab ich bemerkt dass meine SD Karte wohl einen

Fehler, ich kann da nichts mehr beschreiben, löschen geschweige denn formatieren... (auch nicht mit SD Formatter etc.)

 

Naja jedenfalls konnte ich mit der Tastenkombination Vol Up+Down + Power in eine art Downloadmodus wechseln und dort

die Datei aus der Firmware B114 installieren welche ich auf einer anderen SD Karte ins Telefon getan habe.

 

Seltsamerweise hat Das Update bei etwa 70% mit einem Fehler abgebrochen und mir ist schon das Herz in die Hose gerutscht

aber mit etwas Gedult hat das Telefon dann ganz nochmal gestartet... Puhhhh

 

Danke an @mlerch für die Tips!

Diesen Beitrag teilen


Link zum Beitrag
Pille_S5830

 

Du kannst wohl wie ich gelesen habe mit HuaweiUpdateExtractor eine flashbare zip von der FW erstellen.

 

 

 

Hieße auf die SD Karte kopieren sofern die noch erkannt wird und dann über TWRP flashen.

 

 

 

Ist zwar von einem anderen Modell aber warum sollte es beim Mate S nicht gehen.

 

 

 

Hier der Beitrag hier aus dem Forum :

 

 

Gruß Pille

 

Edit : 

 

War ich wohl zu spät aber gut das es nun wieder läuft :)

 

Noch ein schönes Wochenende :wave:

bearbeitet von Pille_S5830

Diesen Beitrag teilen


Link zum Beitrag
TheFlown

Ein kleines Problem habe ich aber inzwischen gefunden, die Einhandbedienung funktioniert leider nicht.

Hatte jemand schon mal das Problem?

Gesendet von meinem HUAWEI CRR-L09 mit Tapatalk

Diesen Beitrag teilen


Link zum Beitrag
mlerch

Mach mal einen Werksrest und installiere eine Firmware Vollversion als lokales Update. 

Diesen Beitrag teilen


Link zum Beitrag

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gast
Auf dieses Thema antworten...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Neu erstellen...

Wichtige Information

Bitte beachten Sie folgende Informationen: Nutzungsbedingungen und Impressum & Datenschutzerklärung. Wir haben Cookies auf deinem Gerät platziert, um die Bedienung dieser Website zu verbessern. Du kannst deine Cookie-Einstellungen anpassen, andernfalls gehen wir davon aus, dass Du damit einverstanden bist.